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General Information

Legal Notice
Information furnished is believed to be accurate and reliable. However, CORRSYS-DATRON
assumes no responsibility for the consequences of use of such information nor for any infringement
of patents or other rights of third parties which may result from its use. No license is granted by
implication or otherwise under any patent or patent rights of CORRSYS-DATRON. Specifications
mentioned in this publication are subject to change without notice and do not represent a commit-
ment on the part of CORRSYS-DATRON. This publication supersedes and replaces all information
previously supplied.

All brand names are trademarks of their respective holders.

Copyright Notice
©Copyright 2001, CORRSYS-DATRON

Revision
D113-50-02-02E   11/04 

Contact
International Headquarters:
CORRSYS-DATRON Sensorsysteme GmbH
Charlotte-Bamberg-Str. 12
35523 Wetzlar / Germany
Phone ++49 (6441) 9282-0
Hotline ++49 (6441) 9282-82
Fax ++49 (6441) 9282-17
E-mail sales@corrsys-datron.com
URL www.corrsys-datron.com

North American Headquarters:
CORRSYS-DATRON Sensorsystems, Inc.
21654 Melrose Avenue, Building 16
Southfield, MI 48075 / USA
Phone ++1 (248) 204-0850
Toll-free++1 (800) 832-0732
Fax ++1 (248) 204-0864
E-mail 1. USA-sales@corrsys-datron.com  or  2. sales@datron.com 
URL www.corrsys-datron.com
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Safety Instructions
Please read carefully before operating the equipment.

CORRSYS-DATRON is not responsible for damage that may occur when this system is used in
any way other than that for which it is intended.

To assure safe and proper operation, all supplied equipment, components and/or accessories must be
carefully transported and stored, as well as professionally installed and operated. Careful maintenance
and usage in full accordance with operating instructions is imperative.

CORRSYS-DATRON equipment should be installed and operated only by qualified persons who are
familiar with devices of this type.

Local regulations may not permit the operation of motor vehicles on public highways while the
equipment is mounted on the exterior of the vehicle.

� Use the equipment only for intended applications. Improper application is not advised.

� Do not modify or change the equipment or its accessories in any way.

� Improper use or mounting of the equipment may affect the safety of the vehicle and/or occupants.

� The equipment must not be mounted and/or operated in any way that may compromise vehicle or 
and/or occupant safety.

� Equipment must be mounted firmly and securely.

� Use only original equipment, components and/or accessories included in the scope of delivery.

� Do not mount equipment, components and/or accessories near heat sources (e.g. exhaust).

� Do not use defective or damaged equipment, components and/or accessories .

� Always note correct pin assignments and operating voltages when connecting equipment to
power supplies, data acquisition/evaluation systems, and/or any other applicable system or
component. Equipment may be damaged if not properly connected and/or operated.

� For additional information, please call the CORRSYS-DATRON Hotline: ++49 (6441) 9282-82

Danger

Warning

� Use caution when exchanging sensor lamps � lamps are extremely hot, and may cause injury.
� Do not look into sensor lamps � lamps are extremely bright, and may cause eye injury.
� Sensor head can become very hot and may cause injury if power has been applied to the

sensor for extended periods of time. This is especially true if the sensor is used in hot
environmental conditions.

� The sensor and/or sensor components may be damaged if power is applied for extended
periods, especially in hot environmental conditions.

� Disconnect power from the sensor if the vehicle is stationary for extended periods.
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1. Overview

CORREVIT®

S-CE w/Gyro

Two different sensors are brought together in one compact system, exploiting the technical advantages of
each. The CORREVIT® S-CE Sensor with integrated gyroscope simultaneously acquires the following
parameters:

� Driving speed
� Yaw rate
� Fixed drift angle
� Transversal speed

The CORREVIT® S-CE Sensor with integrated gyroscope uses proven optical correlation technology to
ensure the most accurate possible signal presentation. This technology incorporates a high-intensity light
source that illuminates the test surface, which is optically projected by the sensor onto an optical grating
system. Fast, easy mounting and universal applicability distinguish this proven non-contact,
optical sensor.

Easy to set-up and operate, the CORREVIT® S-CE Sensor with integrated gyroscope requires only
one power supply (+12V) and one signal cable. 

The new generation fiber-optic gyroscope is added as a system element for the measurement of
angular velocity (°/s) and can also be retrofitted into most compact CORREVIT® Sensors.

Non-Contact Optical Sensor
with
Integrated Fiber-Optic
Gyroscope

for
precise non-contact and
slip-free measurement of
longitudinal dynamics and
angular velocity
Art-No.: 1.002.13  
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The compact, lightweight CORRSYS-DATRON S-CE Sensor with integrated fiber-optic
gyroscope is designed for use in dynamic vehicle testing applications requiring highly
accurate measurement of the following variables:

� Distance

� Speed

� Acceleration

� Longitudinal and transversal speed

� Tire slip angle

� Drift angle

� Yaw angle

Applications

� Extremely high measuring accuracy � better than 0.1%
(or better than 0.1° angular resolution) as a result of
precision optical gratings and digital signalprocess-
ing.

� Compact, robust but lightweight sensor construction
with integrated filter electronicsand serial interface.

� Programmable standardized analog and digital signal
outputs using the latest processortechniques, fast and
easy calibration.

� Any required measurement quantity available.

� Easy operation, mounting angle correction and direct
connection to PC or other evaluation systems.

� Tested and used under extreme weather conditions.

� Negligible service and maintenance requirements as a
result of durable technology.

Features

© 2004 CORRSYS-DATRON Sensorsysteme GmbH, Germany D113-50-02-02E     10/04
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2. Extent of delivery

Standard delivery
1. S-CE Sensor with Integrated Fiber-Optic Gyro #C100200G
2. Power Cable  # K001.40.52
3. Signal Cable # K001.8C.53
4. Breakout Adaptor Cable: 25-pin DSUB to 5 BNC
7. Halogen Lamp 12V, 35W, 24° #200032
8. Mounting Screws

Options/Accessories
5. CE_CAL Communication Cable
6. CD-ROM with CeCalWin Software and User Manual 
9. Calibration certificate ISO 9000 ++

� Suction Mounting Hardware 
� Transport Case #20600
� Replacement Halogen Lamp 12V, 35W, 24° #200032

About replacement
halogen lamps
It is recommended that only
halogen lamps supplied by
CORRSYS-DATRON be used
as these have been subjected 
to a special treatment. Optimal
sensor function can only be
assured when using original-
equipment lamps.
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3. Installation and connection

1. Connect the CE_CAL Communication
Cable to the data port of the Sensor.

2. Connect the Power Cable to the power
input of the Sensor.

3. Connect the CE_CAL Communication
Cable to the serial port of the PC or laptop
operating CeCalWin Software or trigger
box (trigger box is required if calibration
should be started or stopped by a light bar-
rier or a brake switch).

4. Connect the Power Cable to 12 V DC
power supply.

3.1 Connecting the Sensor to PC or laptop for calibration and
sensor-setting adjustments with CeCalWin Software

to computer
serial port

to power
supply

data port

power input
12 V DC

1. Connect to the Signal Cable to the
Breakout Adaptor Cable.

2. Connect the Signal Cable to the data port
of the Sensor.

3. Connect the Power Cable to the power
input of the Sensor.

4. Connect the BNC Connectors of the
Breakout Adaptor Cable to the data acqui-
sition system.

5. Connect the Power Cable to 12 V DC
power supply.

3.2 Connecting the Sensor to data acquisition

to data
acquisition

to power
supply

data port

power input
12 V DC
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3.3.1 Pin assignments: signal

Binder D-Sub Assignment Signal Signal Type & Description

A 1 shield (white) GND  ANA1

B 2 white ANA1 Speed - analog

C 3 brown ANA2 Slip angle - analog / Transversal speed - analog

D 4 shield (brown) GND  ANA2

E 13 green TTL1 Longitudinal distance - digital

F 12 yellow NA

G 21 gray Gyro Gyro output

H 20 shield (gray/pink) GND Gyro

J 24 blue NA

K 25 red TTL2 Slip angle - digital / Transversal speed - frequency modulation

L 11 shield (green/yellow) GND TTL
23 shield (red/blue) 

M pink

Plug Socket Assignment Signal

1 & 2 1 & 2 white / brown GND

3 & 4 3 & 4 blue / black +12 V

Binder

3.3.3 Pin assignments: 12 V DC power supply

Power Supply

3.3.2 Pin assignments: BNC distributor

Reverse polarity protection
The Sensor is equipped with reverse
polarity protection. In the event that polarity
is inverted (9 V - 14.5 V DC), the sensor
will not be damaged, but a red LED will be
illuminated and seen in the sensor optics!
If this happens, disconnect power from the
sensor immediately and correct the power
supply connection.

3.3 Pin assignments

(view: soldering side)

Signal Color

Analog 1 (ANA1) red

Analog 2 (ANA2) blue

Digital 1  (TTL1) green

Digital 2  (TTL2) yellow

Gyro black

10.5 V minimum required at the sensor



For optimum performance and accuracy,
the mounting distance from

the lower surface of the sensor body
(not including the spray guard)

to the road surface must be 300 mm ±50 mm.

User Manual CORREVIT® S-CE Sensor with Fiber-Optic Gyroscope

© 2004 CORRSYS-DATRON Sensorsysteme GmbH, Germany D113-50-02-02E     11/04 11

3.4 Mounting the sensor on the vehicle

Mount  the sensor in a longitudinal
orientation, parallel to the vehicle

300 mm

Sensor Body

Splash Guard

Road surface

S-CE mounting jig

Notice:
When using the
sensor in wet or

snowy conditions,
mount it at the front

of the vehicle to
avoid spray and/or

blowing snow.

+50

-50

Caution:
For proper sensor mounting, use only M6 screws with a maximum thread engagement
depth of 10 mm. The use of screws with thread engagement depths of greater than 10
mm can damage the sensor housing and will void the warranty!
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4. Technical data

4.1 Specifications

System parameters of the S-CE Sensor
Speed range                          0.5  to  400 kph
Braking / coasting                             to  0.2 kph
Distance resolution                       1.5 mm
Measurement deviation              < ±0.1%
Angle range                             ±40°
Digital output 1 longitudinal distance 160  to  750 pulses/m
Digital output 2 switchable Output as frequency

-  Frequency modulated angle or transversal speed 
Analog output 1 longitudinal direction 0  to  10 V
Analog output 2 switchable    - 5  to  5 V

-  Transverse speed or tire slip angle 
Power supply                             11.5 to  14.5 V; 40W
Working distance                      300  ±50 mm
Temperature range                Operation: - 25  to  50° C

Storage: - 40  to  85° C
Relative humidity: 5  to  80% not condensed

System of protection                    IP 67
Dimensions (l x w x h)                  approx. 164 x 78 x 84 mm
Weight                                          1.6 kg
Shock                                             50 g half-sine, 6 ms
Vibration                                   10 g, 10  to  150 Hz
Serial interface for connection to the PC, automatic sensor identification, function control

System parameters of the fiber-optic gyroscope
(Type VG910 / VG910S)
Sensitivity approx. 55 mV/°/s ±20%
Maximum measurement range < 200°/s
Drift (temperature corrected) < 30°/h
Drift (constant temperature) < 10°/h
Linearity 0.2%
Sensitivity (1 Hz, 1s) 15°/h
Bandwidth 1000 Hz
Warm-up time approx. 5 min.
Power on to signal output delay time 0.5 s
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Measurement Output Output Channel
Longitudinal speed VL analog Analog 1
Magnitude speed |V| analog Analog 1
Angle β analog Analog 2
Transversal speed Vq analog Analog 2
Pulses/m for longitudinal distance digital Digital 1
Pulses/m for magnitude distance digital Digital 1
Angle β, frequency modulated digital Digital 2

Transversal speed Vq, frequency modulated digital Digital 2

4.2 Measured values

4.3 The calibrated CORREVIT® S-CE sensor (set to 340 pulses/m)
supplies the following pulse form at output DIG 1.

a = 25% of T
b = 75% of T

Pulse forms at a rate of 300 kph:

Conversion of the speed factor into m/s

Frequency f of the S-CE Sensor

T: period

A period of 35.2 µs requires

Pulse forms at a rate of 1 kph

Conversion of the speed factor into m/s

Frequency of the S-CE Sensor

T: period

A period of 10.58 ms requires

300 kph
3.6

83.33 m/s x 340 P/m = 28.333 kHz

= 83.33 m/s

1 kph
3.6

= 0.277 m/s

1
94.444 Hz

= 10.58 ms

1
28.33 kHz

= 35.3 µs

0.277 m/s x 340 P/m = 94.44 Hz

a = 2.64 ms and b = 7.94 ms

a = 8.8 µs and b = 24.4 µs



Analog channel 1 25 Magnitude speed |V|

Analog chanel 2 100 Angle β

Digital channel 1 340 Longitudinal distance (output as pulses)

Digital channel 2 50 Angle (output as frequency)
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On digital channel 2, the angle output is frequency modulated (FM).
The carrier frequency used is 10 kHz and has a range of ±2 kHz.

With a setting of 25 mV / kph for longitudinal speed VL,
a maximum speed of 300 kph can be achieved.

(A special configuration of the S-CE Sensor can measure speeds of up to 400 kph.)

4.4 The S-CE Sensor has been set as follows:

For analog signal representation of speed, the voltage scale may be changed to any of the following:

� 15 mV / kph
� 25 mV / kph
� 50 mV / kph
� 100 mV / kph

A further possibility is to smooth the signal using a moving average filter, which can be adjusted with
different times for averaging. Note that signal detail and dynamics will be decreased the signal becomes
increasingly smooth.

mV
kph

mV
°

pulses
m

Hz
°

4.5 Values to be measured

The above settings produce the following values:
100 kph = 2.5 V
200 kph = 5.0 V
300 kph = 7.5 V
400 kph = 10.5 V

All signals can be used as inputs to all common data acquisition systems.
Should any problems arise, please contact CORRSYS-DATRON.

Filter Values
� 65.5 ms
� 131 ms
� 262 ms
� 524 ms
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5.1 Introduction
CeCalWin is the Windows* version of the CE_CAL-Software used to configure all CORREVIT® optical
sensors by CORRSYS-DATRON (www.corrsys-datron.com).

The current version, 3.3, is 32-bit and designed for use with Windows 95/98, NT 4.0, Windows 2000,
and XP operating systems. The older CE_CAL-Software cannot be used with these operating systems
because it does not support direct access to the serial interface and is not supported by the Windows
operating system. CeCalWin features a considerably improved user interface making distance and
angle calibration faster and easier. CeCalWin Software can also be operated in parallel with other pro-
grams, contingent upon operating system capabilities.

5.2 Quick-Start Tutorial
The Quick-Start Tutorial provides a brief overview of the installation and basic operation of the
CeCalWin Software package, including back-up of software and sensor settings.

5.2.1 Install the software
CeCalWin Software can be installed in any directory of your file system. To install, insert the program
disk and browse to "Setup.exe". Next, double-click on the file icon and follow the installation prompts.
For faster access to CeCalWin Software, a shortcut is created on your desktop. You can create
additional shortcuts from your desktop, the start menu etc. if you desire. A complete explanation of 
this process can be found in Windows* Help. It is not necessary to change any of the settings in your
operating system when installing CeCalWin.
If possible (though not necessary) install the software unter NT and 2000 using an account to adminis-
trator rights.

5.2.2 Start and license the software
After installing the CeCalWin Software package, start the program by clicking on the program icon or by
accessing the program via Windows Explorer*. Upon program start, you may be prompted to install the
license file, cecalwin.dlf (if it is not already installed in the CeCalWin.exe directory).

The license file will be provided on separate diskette or sent via e-mail. To install it, click on the button
labeled �I have new license file� and text-enter a path to the file, or browse to the file using standard
Windows* operating protocol. Once located, CeCalWin will copy the file into the CeCalWin.exe directory.

5.2.3 Set language preference
The CeCalWin software package provides the option to choose either German or English as the
language in which the interface will be presented. To set the language preference, open CeCalWin and
select Interface>Language, then select either English or Deutsch. You will then be prompted to confirm
the selection. To do so, click OK. As indicated, language preference will be updated upon program
restart or when reading the sensor.

5. Using the CeCalWin Software Package
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5.2.4 Select a COM port
Before connecting a sensor to the computer running CeCalWin, select Interface>Com port, then select
either COM1 or COM2. Baud rate and other COM port parameters are automatically set by the program.

5.2.5 Connect a sensor
Connect the sensor to the COM port selected above.

5.2.6 Make backup copies of the software and sensor settings
Prior to using the sensor, make backup copies of:

� The CeCalWin Software
� Default settings from the sensor

5.2.6.1 Back-up program diskettes
To create back-ups of all delivered software, simply
copy the CeCalWin Software files CD-ROM or other media.

5.2.6.2 Back-up sensor settings
1. Select Sensor>Read Sensor. Sensor settings will appear in the Project Window.

2. Select File>Save As.
3. Select a directory into which the file will be saved.
4. Name the file and select "Save".
5. Saved sensor settings are now available to be written back to the sensor,

should it ever become necessary to do so.

Do not store diskette copies near
electromagnetic fields or anywhere
they will be subjected to extreme
temperatures.

All project files created by CeCalWin are automatically given the filename extension,
".ccw". Project files generated by earlier versions of the program used the extension
".idt". CeCalWin 3.1 and later can open and read both ".idt" and ".ccw" files, but
create only ".ccw" files. NOTE: ".idt" and ".ccw" files are not compatible and CAN NOT
be used together.



User Manual CORREVIT® S-CE Sensor with Fiber-Optic Gyroscope

© 2004 CORRSYS-DATRON Sensorsysteme GmbH, Germany D113-50-02-02E     11/04 17

5.3 Using CeCalWin

5.3.1 Main Program Window
Upon opening CeCalWin, the Main Program
Window will display:

� Menu Bar
� Tool Bar
� Status Bar

After reading a project file (.ccw) or a connected
sensor, available sensor settings are displayed in
the Project Window, shown below.

Menu Bar

Status bar

5.3.2 Project window

The Project Window opens automatically when a sensor is read or a project file is opened. Here, all
selectable sensor calibration settings are displayed within the selectable tabbed sections. Each of the
three sections available in the Project Window can be accessed by clicking on the corresponding tab.
You can also navigate through the tabbed sections using CTRL-TAB key command.

Digital Channels    Analog Channels    Filtering & Angle Offset    CAN Bus

Tool Bar
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5.3.2.1 Menu Bar

File Menu
The File Menu includes the standard options available under the Windows operating system, including:

Open Project (Ctrl+O)
To open a project, select File>Open project and locate the directory in which the desired project file
is saved. From there, double-click the project to be opened or select the project and click the �Open�
button. If a project to which changes have been made is currently open, you will be prompted to save
the changed settings before a new project can be opened.

Close Project
To close a project, select File>Close project. If any changes have
been made to an open project, you will be asked to save the
changed settings before the project can be closed.

Save (Ctrl+S)
Select File>Save to save the current project. If no file name has
been previously assigned to the project, the Save As process will
be executed. Otherwise, the existing file will be overwritten with
the current data.

Save As
Select File>Save As to save the current project as a new file. You can choose to overwrite data to an
existing file name, or create a new file name, as will often be the case. The file extension �.ccw� will
always be added to a new filename. For example, if you name a file �MySensor.sce�, the extension
�.ccw� will be attached automatically. The file will therefore be named �MySensor.sce.ccw�.

Print Preview
Select File>Print Preview and follow standard Windows procedures to see a print preview.

Print (Ctrl+P)
Select File>Print and follow standard Windows printing procedures to print the current sensor
data display.

Exit (Alt+F4)
Select File>Exit to close the program. If any changes have been made to an open project, you will be
prompted to save the project first.

Windows 95/98, Windows NT, Windows 2000, and XP allow file
names of up to 255 characters. For more information about allowable
punctuation characters and other file naming conventions, see
Windows Help.
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Edit Menu
The Edit Menu includes the standard Windows edit functions: Undo, Cut, Copy and Paste.

View Menu
The View Menu includes commands used to View options available in the Program Window.

� Select View>Toolbar to view the Tool Bar.

� Select View>Status Bar to view the Status Bar.
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Read Sensor (F3)
Select Sensor>Read Sensor to read data from the connected sensor. The sensor reading can take up to
20 seconds. If no sensor is connected or if a general communication problem exists, you will receive the
error notification, �Connected sensor unknown!� If a project is open and changes have been made to the
project settings, you will be receive the prompt, �Save changes before reading?�.

Write Sensor (F2)
Select Sensor>Write Sensor to write changes made to the sensor settings in tabbed sections of the
Project Window to the connected sensor.

Display speed in Mph (Ctrl+M)
Select Sensor>Display speed in Mph to display speed values in Mph. Once selected, a checkmark will
appear to the left of Sensor>Display speed in Mph. If not selected, speed values will be displayed in
Kph.

Test Output (Ctrl+T)
Select Test Output to set 5 V on each analog output and 5 kHz on each digital output. Then, the stand-
still LED will blink. 

Calibration (F5)
Select Calibration to access calibration and trigger settings (see Distance & Angle Calibration,
page 25 for complete detail).

Sensor Menu
The Sensor Menu is comprised of commands used to control communication with the sensor. If there is
no sensor connected, or a connected sensor has not yet been read, menu selection is restricted to the
item, Read sensor. When a Project Window is open (e.g. when a project has been opened, or when
data has been read from a connected sensor), the Sensor Menu will be extended to include the full
available range of selectable sensor settings.
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Interface Menu
The Interface Menu includes commands used to control interface options.

COM port
Before connecting a sensor to the computer running CeCalWin, select Interface>Com port, then
select the COM port to which the sensor will be attached. Baud rate and other COM port parameters
are automatically set by the program.

Language
The CeCalWin software package provides the option to choose either German or English as the
language in which the interface will be presented. To set the language preference, open
CeCalWin and select Interface>Language, then select either English or Deutsch.

You will then be prompted with the following dialog box. Click OK to confirm the selection.
As indicated, language preference will be updated upon program restart.
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5.3.2.3 Status Bar
The Status Bar displays text information about the connected sensor. If an error occurs during
communication with the sensor, the step in which the error occurs will be displayed. This
information provides the user a diagnostic basis from which the required correction can be
initiated. In the event that the error condition cannot be rectified, please be sure to note the error
message before contacting the manufacturer.

Help Menu
The Help Menu includes commands used to View options available in the Help Menu.

� Select Help>Help Topics to access Help Topics.

� Select Help>About cecalwin� to access version and license information.

5.3.2.2 Tool Bar
All Tool Bar functions correspond to functions also available in the Menu Bar.
See illustration below to reference equivalent menu functions.

1. 2. 3. 4. 5. 6. 7. 8. 9.

1. File>Open project
2. File>Save
3. Sensor>Calibration�
4. Sensor>Test Output (5kHz, 5V)
5. Sensor>Display speed in Mph
6. Sensor>Read Sensor
7. Sensor>Write Sensor
8. Help>Help Topics
9. Help>About cecalwin�
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5.3.2.4 Project Window Settings
The Project Window displays all selectable sensor settings. Within the SL Project Window, there are
three tabbed sections: Digital Channels, Analog Channels and Filtering & Mode.

Digital Channels
Both digital outputs can be configured from within this section per the following descriptions.

Digital channel 1
Options in the Digital channel 1 section are used to control variables related to digital output 1.

Measurement Mode (Default setting = |V|)
These options allow the selection of either:

|V| - magnitude speed
or
VL - longitudinal speed

Resolution (Default value = 340)
Selects the number of digital pulses/meter to be output.

Calibration factor (Default value = 1000)
This field displays the value that is produced during Calibration to correct for mounting
errors, surface changes, etc. Value can also be changed manually using the scroll-edit
function.
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Output function channel 1+2 (Default setting = Frequency)

These options control the output of data from the sensor:

� Frequency - Digital channels 1 and 2 provide calculated, calibrated and filtered digital 
output pulses as selected in the Measurement Mode sections.

� Raw data - Digital Channels 1 and 2 provide the right and left optical channel pulses 
without any calculation for angle, filtering, or calibration.

Digital channel 2
Options in the Digital channel 2 section are used to control  the funtion of digital output 2.

Measurement mode (Default setting = Angle)
These options provide a choice of two measurement modes. Note that in choosing either of the
two selections below, the unit of measurement will be changed in accordance with the chosen
measurement mode:

� Angle (slip angle) - the unit �degree� will be used. 
� Vq (transverse velocity) - the unit �kph� will be used.

Resolution (Default values = 50Hz / Degree for angle, 100Hz/kph for Vq)
Use the scroll-edit function to set the resolution of the frequency modulated output of
digital channel 2 
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Analog Channels
The analog outputs can be configured from within this section per the following descriptions.

Analog Channel 1
Options in the Analog Channel 1 section are used to control variables related to speed measurement.

Data Source (Default setting = |V|)
These options allow the selection of either corrected or uncorrected speed signals:

� |V| (magnitude speed) - the speed value produced by mathematical correction 
of angle deviance.

� VL (longitudinal speed) - without consideration of angle deviance.

Resolution (Default value = 25 mV/Kph)
Use the scroll-edit field to set the resolution of the analog output channel 1. 

Offset (Default value = 0 mV)
Use the scroll-edit field to define an additional offset value.
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Analog channel  2
Options in the Analog Channel 2 section are used to control variables related to angle measurement.

Data Source
Data source is pre-set to:

� Vq (transverse velocity)

Resolution (Default value = 100 mV/Kph)
Use the scroll-edit field to set the resolution of the analog output channel 2. 

Offset (Default value = 0 mV)
Use the scroll-edit field to define an additional offset value.
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Analog channel  3
Options in the Analog Channel 3 section are used to control variables related to angle measurement.

Data Source
Data source is pre-set to:

� Angle (slip angle)

Resolution (Default value = 100 mV/Kph)
Use the scroll-edit field to set the resolution of the analog output channel 3. 

Offset (Default value = 0 mV)
Use the scroll-edit field to define an additional offset value.
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Filtering and Angle Offset

Averaging  (Default value = 128 ms)
A moving average of the selected measurement value will be performed. Shorter time values produce
more detailed measurement, but also increases signal fluctuations.

Angle Offset  (Default value = 0.0 deg.)
Use this option to correct the measured value in a range of -5.0° to +5.0°. This value can also be
determined via calibration (see Distance & Angle Calibration, page 25).
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CAN Bus (optional)
Settings in this section apply only to sensors fitted with the optional CAN bus interface. 
Also see CAN Protocol documentation for further information.

Baud rate (Default value = 1 Mbaud)
Sets the communication baud rate for the CAN Protocol.

ID Sensor  (Default setting = XTD)
Sets Sensor Message Identifier (See CAN Protocol documentation).
Select either Standard (STD) or Extended (XTD) identifier mode.
(Default value, STD = 7 FA)
(Default value, XTD = 1 FFFFFFA)

Continuous Send Mode  (Default setting = selected) (Default value = 32 ms) 
Sets sensor to send CAN message frame at regular intervals, selectable in 4 ms increments.

Remote Frame Mode  (Default setting = not selected)
Sets sensor to respond to Remote Frame requests.

Trigger Frame Mode  (Default setting = not selected)
Sets sensor to respond to CAN Trigger Frames.

ID Trigger Frame  (Default setting = not selected)
Sets Message Identifier for the trigger frame to which the Sensor responds.
(Default value, STD = 700)
(Default value, XTD = 10000000)
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5.4 Distance and Angle Calibration
To perform distance and angle calibration, a known measured distance must be specified and
subsequently measured with the sensor in a test drive.

NOTE:
� The new distance calibration factor is calculated based the number of pulses generated

as the sensor travels over this known distance.

� The vehicle must be driven in a straight line during the test run. Angle error correction
is based on the measurement made over this known distance.

1. If a light barrier interface or external trigger unit will be used, connect either trigger device via the 
DCD line of the serial interface.

2. Be sure that the vehicle is at a complete standstill, then select Sensor>Calibration� to open
the  �Distance & Trigger� dialog box.

3. Set the known distance to be traveled in the test drive using the scroll-edit box labeled �Distance:�
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4. Select �Distance� and �Angle� under �Values to calibrate�. Values can also be calibrated individually.

5. Beneath the heading, �Pulses count for end�, use the scroll menu to select the number of trigger
pulses to be used in the test run (the minimum is 2, one for start and one for stop). As an example,
if the test track has a light barrier every 200 m and you want to do a calibration of 1000 m, then
you would require 6 trigger pulses.

6. Beneath the heading �Delay after trigger [ms]� use the scroll menu to select the minimum time  
between 2 trigger pulses for each of the 2 pulses to be considered as separate pulses.  

7. Click OK to continue, or Cancel to return to the Project Window.

8. The �Sensor calibration�� dialog box will open.

9. To begin the calibration run, click Start (or click Cancel to return to �Distance & Trigger� dialog box). 
� Calibration distance (as selected in the �Distance & Trigger� dialog box) is displayed

below the heading �End distance [m]�.
� Actual distance traveled will be displayed below the heading �Distance [m]�.
� Elapsed time will be displayed below the heading �Time [s]�.
� Minimum angle deviation will be displayed below the heading �Min angle [deg]�.
� Maximum angle deviation will be displayed below the heading �Max angle [deg]�.
� Angle correction will be displayed below the heading �Angle [deg]�.
NOTE: maximum allowable angle correction is ±5°.
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10. When the end of the calibration distance has been reached, click �Stop�
(or click Cancel to return to �Distance & Trigger� dialog box).

11. New calibration factors will appear in the Results of calibration� window. To accept these values 
select each of the �Accept� buttons individually, or click �Accept all� to simultaneously accept all new
calibration values, then click OK. To reject new calibration values, click �Cancel�. 

12. To write the new calibration factors to the sensor, select Sensor> Write Sensor.
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5.5 Troubleshooting

The first step in troubleshooting should always be to check all connections:

� First, check the wiring connection between sensor and PC/Notebook.
� Also be sure to note which serial interface is used for sensor connection.
� Open menu item, Sensor>Interface and choose the correct interface.
� Proper communication with the sensor should now be possible.
� Check this by selecting the Read Data command in the Sensor Menu.

Error messages and possible causes:

�Connected sensor unknown!�
This message usually indicates that no sensor or an unknown sensor is connected. This message often
appears as a result of improper or incomplete connection. Double-check all connections and also check
the sensor interface by opening the menu item, Sensor>Interface and choosing the correct interface.

In some instances, this message will be produced because the connected sensor is not supported by
the software. CeCalWin supports only CORREVIT® S- and L- series sensors.

�Could not read sensor!�
This error message typically occurs during the first reading of the sensor. Check to be certain the
software is compatible with the sensor.

�Could not write file�
This message indicates that faults occurred as a file was being written. Check to be certain that the
storage media the file is being written to has sufficient space for the file and that the storage media
is not write-protected. Write permission can be changed in the directory (under Windows NT* and
Windows 2000*). 

�Loading error�
This message indicates that faults occurred as a file was being read. Be sure that the file is a
CeCalWin project and that it has not been damaged by a write error. If a write error has occurred,
data loss can result.

�Listindex out of bounds�
An internal program fault has occurred during measurement. Close all program windows and read
the sensor again.

Additional Notes On Error Correction

Please contact us if other faults occur and no error messages are displayed so we can correct these
issues in subsequent software versions and service releases.

For errors relating to the Windows* operating system, please see Windows Help or consult the Windows
user manual.

*Windows, Windows NT and Windows 2000 are registered trademarks of the Microsoft Corporation.
**Windows Explorer is a registered trademark of the Microsoft Corporation.


